Hỏi đáp mọi chủ đề liên qua đến công nghệ thông tin, internet, lập trình, SEO...
Nội quy chuyên mục: Hỏi đáp mọi chủ đề liên qua đến công nghệ thông tin, internet, lập trình, SEO...

- Chuyên nhận giải đáp thắc mắc sử dụng Word, Excel, Power Point

- Ai cần download driver hay Firmware cho máy tính máy in, thì vào đây nhé, tìm gì cũng có Driver 360

- Cập nhật tin tức với Mr Công nghệ tại đây
By Bronsonn
#687527 Như tiều đề, bạn nào biết mong giới thiệu qua hộ mình với,

Ai biết cách thiết kế mạng LAN giữa 2 domain trên packet tracer xin chỉ giùm với .
By chuong_vang
#687644 Yêu cầu cần giải quyết:



1.IP subnetting : - Each Ethernet network or VLAN requires 100

- Use VLSM so that IPs are provides only as much as required.

2.IP configuration : - Standar configuration : Creat standar configuration on all routers (hostname, cisco password, meaningful banner and description, full host table...)

- Routing protocol : Use OSPF routing protocol for the network sections as described in the topology.

3.VLAN & VTP configuration : - VTP domain name CCNA, pass cisco. Creat 2 Vlan : Admin & Sale.

- Enable suitable Trunk interface at each Switch.

- InterVlan routing for 2 VLAN on Danang's router.

4.Frame Relay Configuration : Configure Frame-relay network with 2 point to point interface on Gateway and ISP router.

5.NAT & PAT : Allow all hosts on Sale VLAN access internet.

6.ACL Configuration : Only hosts on Admin VLAN can telnet to Routers.

Cách giải bài toán này trên Packet Tracer:

Tùy vào cách chia của mỗi người ta có thể lấy dải địa chỉ cho từng mạng, ở đây mạng lớn 192.168.0.0/16 sẽ được chia thành 4 mạng con theo phương pháp VLSM (Vary Length Subnet Mask)



bạn kích vào Frame Relay chọn config->chọn serial 0, điền tên và sô DLCI vào khung name và DLCI rồi kick add. Tương tự như thế với serial 1. Sau đó kick vào Frame Relay trong connection và chọn from serial 0 to serial 1 kick add thế là xong trong phần Frame relay.

Tiếp theo ta phải cấu hình trong cả 2 routers ISP và Gateway.

Tại ISP Router :


Router>enable

Router#configure terminal

Router(config)#hostname ISP

ISP(config)#interface s0/1/0

ISP(config-if)#no shutdown

ISP(config-if)#ip address 200.0.0.2 255.255.255.252

ISP(config-if)#encapsulation frame-relay

ISP(config-if)#frame-relay interface-dlci 222

Tương tự với Gateway Router.

Sau khi write các bạn kiểm tra bằng cách ping giữa 2 routers ISP và Gateway với nhau.


Về phần Standar configuration các bạn tự làm nhé. Mình làm pass cisco cho các password.

Mình trình bày tiếp OSPF Routing protocol : sau khi cấu hình standar ta sẽ dùng lệnh show để xem và kiểm tra các địa chỉ IP.

Tại Gateway Router :

Gateway(config)#router ospf 10

Gateway(config-router)#network 192.168.1.4 0.0.0.3 area 0

Tại Hanoi Router :

HN(config)#router ospf 10

HN(config-router)#network 192.168.1.4 0.0.0.3 area 0

HN(config-router)#network 192.168.1.0 0.0.0.3 area 0

Tại Danang Router :


DN(config)#router ospf 10

DN(config-router)#network 192.168.1.0 0.0.0.3 area 0

Tuy nhiên vẫn còn thiếu 2 mạng VLAN nữa nên ta chưa hoàn thành phần hội tụ mạng này được.

Bây giờ cần giải quyết 2 mạng VLAN. Oke, chiến sang Vlan và VTP luôn .

Bây giờ ta chiến đến con Switch VTP Server và VTP Client. Tạo ra 2 Vlan Admin và Sale cùng với việc add vào cổng port của switch tại VTP Server và thông qua VTP ta chuyển 2 Vlan qua VTP Client để đến với Danang Router.

Tại VTP Server :


VTPServer(config)#vlan 2

VTPServer(config-vlan)#name Admin

VTPServer(config-vlan)#vlan 3

VTPServer(config-vlan)#name Sale

VTPServer(config-vlan)#interface f0/2

VTPServer(config-if)#switchport mode access

VTPServer(config-if)#switchport access vlan 2

VTPServer(config-if)#interface f0/3

VTPServer(config-if)#switchport mode access

VTPServer(config-if)#switchport access vlan 3


VTPServer(config)#interface f0/1

VTPServer(config-if)#switchport mode trunk

Sau khi thực hiện xong bạn có thể kiểm tra bằng cách dùng lệnh : Show interface vlan

Tiếp tục là tạo VTP domain :


VTPServer(config)#vtp domain ccna

VTPServer(config)#vtp password cisco

VTPServer(config)#vtp phiên bản 1

VTPServer(config)#vtp mode server


Bây giờ trên VTP Client ta chỉ cần các câu lệnh sau :


VTPClient(config)#vtp domain ccna

VTPClient(config)#vtp password cisco

VTPClient(config)#vtp phiên bản 1

VTPClient(config)#vtp mode client

VTPClient(config)#interface f0/9

VTPClient(config-if)#switchport mode trunk


Oke thế là Vlan và VTP, ta hội tụ mạng thôi:

Tại Danang Router :


DN(config)#interface f0/0.1

DN(config-subif)#encapsulation dot1Q 2

DN(config-subif)#ip address 192.168.0.1 255.255.255.128

DN(config-subif)#interface f0/0.2

DN(config-subif)#encapsulation dot1Q 3

DN(config-subif)#ip address 192.168.0.129 255.255.255.128

Sau khi write xong bạn kiểm tra bằng cách ping các mạng Vlan với nhau và với Danang Router.

Tiếp tục tại Danang Router :


DN(config)#router ospf 10

DN(config-router)#network 192.168.0.0 0.0.0.127 area 0

DN(config-router)#network 192.168.0.128 0.0.0.127 area 0

Oke, thế là xong phần hội tụ.

Bây giờ đến phần NAT & PAT Configuration :

Theo yêu cầu đề bài ta phải dùng PAT (tìm hiểu thêm về NAT - nếu không hiểu .

Đầu tiên cần quảng bá mạng 192.168.0.0/16 ra ngoài internet bằng ip router tĩnh 0.0.0.0 0.0.0.0 tại Gateway Router :

Gateway(config)#ip route 0.0.0.0 0.0.0.0 200.0.0.2

Tiếp theo là cho phép Vlan Sale ra ngoài :

Gateway(config)#access-list 1 permit 192.168.0.128 0.0.0.127

Gateway(config)#ip nat inside source list 1 interface s0/1/1 overload


Gateway(config)#interface s0/1/1

Gateway(config-if)#ip nat outside



(tài liệu của Tran Dinh)
Kết nối đề xuất: